Tutorial Switch

<< Inapoi
Inainte >>

Introducere

Un switch este un dispozitiv care interconecteaza diferite echipamente de retea pe baza adreselor MAC.


Switch

Un switch de retea opereaza la nivelul 2 in ierarhia OSI.
Conexiunile de date sunt de 10/100/1000 Mb/s in mod half duplex sau duplex.
In mod half-duplex, switch-urile transmit pe rand (unul transmite si celalalt receptioneaza si invers), pe cand in mod duplex, ambele transmit si receptioneaza simultan.


Configurarea unui switch Cisco

In retelele mari de telecomuniatii, switch-urile Cisco sunt cele mai folosite.
La prima configurare a switch-ului, trebuie sa ne conectam cu PC-ul pe interfata seriala RS232 (consola) cu un cablu serial (apoi vom putea accesa switch-ul si distant, folosind SSH sau Telnet). Pentru conectare, folosim aplicatia gratuita Putty:


Putty

Setam parametrii de conectare si ne conectam. Va aparea prompt-ul:


Switch>


Acum ne aflam in modul de lucru: user exec mode. Aici se pot da doar cateva comenzi si interogari.
Pentru a trece la modul urmator (privileged mode), vom tasta enable, si prompt-ul se va schimba


Switch#


Pentru configurare, vom trece la nivelul de acces: global configuration mode, tastand: configure terminal, si prompt-ul se va schimba:


Switch# configure terminal
Switch(config)#


Configurare VLAN-uri.

Retelele locale virtuale (VLAN-uri), separa in mod logic o retea in mai multe subretele. Ele se identifica prin VLAN ID.
Configurarea VLAN-urilor se face pe interfetele (porturile) switch-urilor.


Configurarea VLAN-ului de management.

Pentru a putea accesa switch-ul distant, prin SSH sau Telnet, trebuie sa configuram un VLAN de management. Acest lucru se face astfel:


Switch>enable
Switch#configure terminal
Switch(config)#vlan 100
Switch(config-vlan)#name management
Switch(config-vlan)#exit
Switch(config)#interface Fa0/1
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 100


Apoi vom configura IP-ul de management pentru aceasta interfata:


Switch(config)#interface vlan 100
Switch(config-if)#no shutdown
Switch(config-if)#ip address 192.168.1.254 255.255.255.0


Acum switch-ul va putea fi accesat de pe statia e management la adresa: 192.168.1.254.


Configurarea VLAN-urilor de trafic.

Switch# configure terminal
Switch(config)# vlan 901
Switch(config)# vlan 903
Switch(config)# interface vlan 901
Switch(config-if)# ip address 192.168.1.1 255.255.255.0
Switch(config-if)# no shut
Switch(config-if)# interface vlan 903
Switch(config-if)# ip address 172.168.1.1 255.255.255.0
Switch(config-if)# no shut
Switch(config-if)# interface gigabitethernet 0/1
Switch(config-if)# switchport access vlan 901
Switch(config-if)# interface gigabitethernet 0/2
Switch(config-if)# switchport access vlan 903
Switch(config-if)# exit


Modul trunk.

Pentru conectivitatea intre echipamente aflate in acelasi VLAN dar conectate fizic in switch-uri diferite, trebuie sa configuram legatura intre switch-uri in mod trunk.
Configurarea switch-ului 1:


Switch1>enable
Switch1#configure terminal
Switch1(config)#int fastEthernet 1/1
Switch1(config-if)#switchport mode trunk
Switch1(config-if)#switchport trunk allowed vlan all
Switch1(config-if)#


Si configurarea switch-ului 2:


Switch2>enable
Switch2#configure terminal
Switch2(config)#int fastEthernet 1/3
Switch2(config-if)#switchport mode trunk
Switch2(config-if)#switchport trunk allowed vlan all
Switch2(config-if)#


Configurare gateway.

Aceasta se realizeaza folosin comanda:


Switch(config)# ip default-gateway 192.168.100.1


Salvarea configuratiilor se face utilizand comanda:


Switch# copy running-config startup-config


Stergerea unui VLAN (de exemplu VLAN 901):


no VLAN 901


<< Inapoi
Inainte >>